FAQ  •  Login

Fatal Error 22 & 13 Upon Startup

<<

GreenOnion

Posts: 2

Joined: Wed Jan 06, 2016 6:43 pm

Cars: 2009 Mazdaspeed 3

Post Wed Jan 06, 2016 6:56 pm

Fatal Error 22 & 13 Upon Startup

Hello All,
I have been having plenty of trouble with getting Automation to run so far. I have tried every tactic in the forums you can name, reinstalling the game, verifying the cache, reinstalling DirectX, .NET, and even following the advice from zeussy linked to here:

viewtopic.php?f=16&t=5795&p=65689&hilit=Automation_Shipping_Steam.exe#p65689\

Nothing has worked so far until I followed zeussy's advice, and I went from a "Automation_Shipping_Steam.exe has stopped working" to "Fatal Error" (picture attached). Also attached is the gamelog.txt, although it may not have much use. Any help will be appreciated, as at this point I am desperate to get this game to work. Thanks!
Attachments
GameLog.txt
(87 Bytes) Downloaded 76 times
fatal_error.PNG
fatal_error.PNG (48.93 KiB) Viewed 1760 times
<<

zeussy

User avatar

Developer - Lead Programmer
Developer - Lead Programmer

Posts: 745

Joined: Wed Apr 14, 2010 2:32 am

Location: Wellington - New Zealand

Cars: A crashed 1992 Suzuki Cappuccino

Post Thu Jan 07, 2016 9:24 am

Re: Fatal Error 22 & 13 Upon Startup

I assume you have not replaced the lua51.dll within the Automation install?

This looks like some other application is using a lua51.dll and windows is loading that for Automation instead of the one that comes with Automation.

You might want to try closing all other applications, or searching your computer for lua51.dll to try and find the culprit. This looks like it is a slight fault in the design for LuaJIT (as it is a drop-in replacement for lua51), they both have the same dll name, and windows DLL Resource management does not want to load duplicates of the same thing.
Lead Progammer (The Guy that makes stuff happen!)

Follow us on
Twitter - http://twitter.com/AutomationGame
Facebook - http://www.facebook.com/AutomationGame

Come chat to us at http://automationgame.com/irc
<<

GreenOnion

Posts: 2

Joined: Wed Jan 06, 2016 6:43 pm

Cars: 2009 Mazdaspeed 3

Post Mon Jan 11, 2016 5:00 pm

Re: Fatal Error 22 & 13 Upon Startup

I have replaced lua51.dll with the link listed in the first post, and I now have lua51.1.dll in the same folder. I tried looking through my computer for another lua51.dll, found another copy in my "Downloads" folder and deleted it, but the problem still persists. I tried closing all applications and restarting several times as well.

Return to Support

Who is online

Users browsing this forum: No registered users and 20 guests

cron